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The base material 
This guide quickly shows you how to make a simple bluray disc using 
Blu-Disc Studio (BDS) tools. It will be a basic disc with a simple menu. 
But once you can do this, you may want to do more and it is time to 
read the parts of the Blu-Disc User’s Guide that informs you about all 
the additional features of Blu-Disc Studio. 

What you need 

To create a bluray disc following the instructions in this guide you 
need: 

1. An installed and working version of Blu-Disc Studio on a 64-bits 
Windows-8, 10 or 11 system.  

2. Three movies that are suitable to become part of the bluray 
disc that we will use 

3. Fonts to display texts on menus 
4. An image (like an arrow or checkmark) to indicate what movie 

to select from the menu  (a “button” it is called) 
5. A background movie for the menu background.  
6. Either: 

a. A software bluray player like Cyberlink’s PowerDVD 
b. A physical bluray burner to burn the result on a 

(re)writeable bluray disc that can be played on a 
standaloner bluray player 

Requirements for each 

A special zip file has been created with ready-for-use components. It 
includes three short Star Wars trailers demuxed in video, audio and 
subtitle streams, a “black menu movie” and checkmark button and 
some Arial font files. Also a version of the tsMuxer (de)muxer tool has 
been included. But feel free to experiment with your own movies and 
button images of course! 

Movies 
Movies that can be used on a bluray disc have to adhere to special 
requirements set by the Bluray Disc Association, BDA for short. Usually 
they have image and sound combined. For BDS these files must be 
demuxed into separate video and audio streams.  

The demuxed streams must be BDA compliant: 

• Video at 1920 x 1080 pixels or 1280 x 720 pixels in AVC format. 
File type .264 (if the decoder gives .h264, simply rename) 

• Audio in lossy Dolby Digital (file type .ac3) or lossless LPCM 
(file type .wav) at sample rate 48 kHz (not 44.1 kHz which is 
the standard CD rate) 

• Subtitles must be in the .srt text format (.sup image format is 
also supported) 

If the source files have streams different from these requirements, you 
need to transcode them first into the proper format. Then you use a 
demuxer to create the separate video and audio stream. 
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• You can inspect whether your video file complies to BDA 
standards by reading its characteristics with the freeware tools 
MediaInfo (from https://mediaarea.net/en/MediaInfo ) 

Several tools can perform the transcoding of formats such as AVI,  
MKV, MP4, MTS to the preferred format .M2TS which has the BDA 
compliant streams that can be demuxed. 

• A transcoder is HD Video Converter Factory Pro of the 
Wonderfox company  (much of the functionality is free to use) 
(https://www.videoconverterfactory.com/ ) 

• Freeware demuxers are ffmpeg (https://ffmpeg.org/ ) or 
tsMuxer (https://www.videohelp.com/software/tsMuxeR ) or 
Haali splitter (https://haali.net/mkv/ )  
The kit provided for this project contains the tsMuxer. 

The kit for this project contains three short trailer movies in HD 1920 x 
1080 pixel resolution with Dolby stereo sound and English subtitle 
files. 

Fonts 
Any TrueType font will do and Windows comes with several in the 
system folder  C:\Windows\Fonts  (if C: is the system drive). You may 
have additional ones on purchased fonts CDs or internet collections. 
Select one or two fonts and copy them to the BDS project folder 
(discussed next). 

Arial is a standard font available on all systems and used in the 
provided kit for this project. The font file is copied from the (hidden) 
Windows fonts folder to the project specific \fonts folder. 

 

Button image 
Any image of type .png suffices. Since it indicates your choice on the 
displayed menu, something pointing is preferred. An arrow, a finger, a 
checkmark image. But any image will do. Keep a reasonable size (like 
38 x 38 pixels) though the size can be adjusted inside BDS. The kit for 
this project contains the checkmark. 

   

Background movie 
BDS always runs a movie in the background of the menu. This makes 
the menu livelier, but it can also be a simple black movie with no 
sound. It doesn’t have to run long – a few seconds suffices as the 
menu movie is repeatedly shown in a loop. The movie must comply to 
the same BDA rules as the ordinary movies. Its resolution determines 

https://mediaarea.net/en/MediaInfo
https://www.videoconverterfactory.com/
https://ffmpeg.org/
https://www.videohelp.com/software/tsMuxeR
https://haali.net/mkv/
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the size of the menu (i.e. 1920x1080 or 1280x720 pixels). The kit for 
this project contains a black movie without sound for 23.9 fps at full 
HD resolution of 1920 x 1080 pixels. 

Player or burner 
Cyberlink’s PowerDVD 
(https://www.cyberlink.com/products/powerdvd-
ultra/features_en_US.html ) is one of the few software players capable 
of imitating a real bluray player. It can read the folders made by BDS as 
if it was a bluray disc. 

Use the free ImgBurn (https://www.imgburn.com/ ) software to burn 
the BDS folders onto a writeable bluray disc (either single layer 25 GB 
or double layer 50 GB in size). I advise you to experiment first with 
some rewriteable bluray discs so any errors made do not leave you 
with coaster discs. ImgBurn will recognize bluray disc projects and 
volunteer to set the disc filesystem to UDF 2.50 and datatype 
Mode1/2048. 

 

https://www.cyberlink.com/products/powerdvd-ultra/features_en_US.html
https://www.cyberlink.com/products/powerdvd-ultra/features_en_US.html
https://www.imgburn.com/




 

Part 2: Create a BDS project 
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Folder structure 
To keep everything in the right spot, it helps to collect all material for a 
BDS project together in one folder tree. 

You may start with starting BDS and create a new project (press 

CTRL/N or click on the new project button ). Just press “next” on 
any of the subsequent windows and questions until the project is 
created. 

• Give a name to the project, “Blu Disc Studio First” 

• Specify the disc or folder where this project will be inserted 
into (e.g.  I:\BDS Projects) 

This results in the creation of the folder I:\BDS Projects\Blu Disc Studio 
First and some subfolders used by BDS. It also inserts a “project.bdmd” 
file in the folder. This is the project file that contains everything you 
specify for the new project. Only the movies are not included but 
linked to. You can give it any other name or duplicate it if you want 
another project using the same files (two versions of a disc). 

For the rest of this book I will use this folder location as the 
project we create. If you used a different location, you need 
to specify that one of course. 

For convenience, once BDS has created the project folder, add some 
folders yourself to keep additional data needed: 

 

• Buttons to contain all button images 

• Disc will contain the BDS created disc image folders for 
burning or playing with a software player. 

• Films to receive all demuxed .264 video and .ac3 (or .wav) 
audio streams 

• Fonts to contain all font files used to display menu text 

• Originals contains all material that is going to be part of the 
bluray disc – mostly the video files in BDA compliant format. 
These are likely not demuxed yet so you may experiment with 
these movie files and your movie converters and demuxers. A 
set of compliant demuxed files must be stored in the \films 
folder. 

The BDS created folder “_History” may not be visible if you have set 
your Windows system not to show hidden folders.  
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The kit provided for this project has the same folder division and is 
populated with files containing the various parts needed. All you may 
need to do is copy those files (or folders) to your newly created 
project. 

Populate folders from the kit 

• One font file is provided in the “fonts” folder. The system 
provided font files are stored in C:\Windows\Fonts  or on CDs 
with fonts for use in Windows. They are of type .ttf. You can 
copy any TTF file of your liking into the \fonts folder. 

• Copy at least one button image in the “buttons” folder. It must 
be of type .png for BDS to see it. The kit provides the 
checkmark image. 

• Store three movies in the “originals” folder and if applicable 
also their .srt subtitle files. 

Make fonts known to BDS project 

The fonts stored in the “fonts” folder can only be used in menus if BDS 
knows about them. Execute the following steps: 

• Open the “project.bdmd” file to start the BDS project (it may 
still be open if you did not close BDS after creating the project) 

• Open the BDS menu Project > Used Fonts 

• In the window that opens, click “Add” 

• Navigate to the I:\BDS Projects\BluDisc Studio First\fonts 
folder 

• Select the arial.ttf font file (or any other you stored in that 
folder) and click “OK” 

• It takes BDS a little while, but in the end the window shows all 
fonts now known to BDS. 

• Click “Close” 

Provide BDS with a muxer 

Unless you bought BDS MX, you need to provide BDS with a muxer 
that is used to mux video, multiple audio and subtitle streams together 
into video files for the bluray disc. The standard muxer for this is the 
freeware tsMuxer. 

Once you downloaded it and stored it somewhere you need to tell BDS 
where it can find it. The kit provides a copy os tsMuxer in the 
\software folder. Create the folder \Program Files (x86)\tsMuxer on 
the system disc and copy thr tsMuxer.exe file into that folder. 

• Click on BDS menu Tools > Options and in the window that 
opens, select the “Muxers” tab.  

• Specify the storage location of the tsMuxer.exe program in the 
“Path” text box. 
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Provide a signature to BDS 
All discs created are “signed” which is something important for 
commercial users. For private use, signing is still required for some BDS 
features so it’s useful to provide the signature now already. But you 
may skip this step for the moment. 

• Click on BDS menu Tools > JAR signing settings 

• In the window text box “Organisation ID 0x” specify a unique 
number different from what you see as default. 

 

Demux files 

• Transcode the movie files in “original” to a BDA compliant 
format like .m2ts in 1920x1080 pixels and Dolby sound at 48 
kHz sampling 

• Demux these files into .264 video and .ac3 (or .wav) streams 
and store these streams in folder “films”. 

• If applicable, also store the .srt subtitle files in “films” 

• Repeat these steps for the (short) menu movie. 

 



 

Part 3: Load movies 
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Project Tree Window 
The movies to play on the final disc are the most important 
ingredients. To load them into the project do the following: 

Add project movie placeholders 

• Ensure the movies are demuxed and the streams stored in the 
“films” folder 

• Add a “movie” entry for each movie you want to add to the 
project: 

o On the BDS window, look at the “Project Tree” 
subwindow and right click on “Movies” 

o Click on “New Movie” on the context menu 
o Give a descriptive name to the movie, like “movie 1” 
o Ignore the “Group” value 

Repeat the previous steps for each movie (you can combine the first 

two steps by clicking on the movie button ( )). 

 

Add movies to placeholders 
Now the project has placeholders for the movies, they must be filled 
with file specifications of the actual movie streams in the “films” 
folder. 

• For each movie click on a movie placeholder (like “movie 1”) 

• In the “Properties” window of the BDS GUI you can specify the 
“Video” stream and the “Audio 1” stream of the real movie in 
the “films” folder. If there are more audio streams, also fill the 
“Audio 2” text box. And for a subtitle the “Sub 1” text box. If 
the language is not english, adjust the value in the dropbox 
box at the end of the audio or subtitle text box. 

• If there are subtitles, specify them in the same order for each 
movie (e.g. English first, Dutch second, French third etc) 

• If there are subtitles, modify the “Group” value of all movie 
placeholders to the same value (e.g. “movie 1”) 

Below we illustrate how placeholder movie 3 is filled with the Star 
Wars Eps 9 trailer. 
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The disc consumption of the movies can be seen in the BDS GUI at the 
top right. A single layer (1L) or double layer (2L) shows the used byte 
count for the movies within the available capacity of 25 GB or 50 GB. 
Click on “1L 25” to change to “2L 50” and vice versa. 

 

Generate chapter index files 

• Click on BDS menu  Project > Project properties.  On the 
“General” tab click on the button “Generate missing index 
files” at the bottom of the window. 

This action creates files that are required to hold the chapter info. 
Even if you have no other chapters than the start of each movie, they 
need to be there. The generation may take some time. 
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Once completed, close the window by clicking on OK. 

If you want to generate automatic chapters (say each 5 minutes) for a 
movie, then do the following: 

• Double click on a movie placeholder. This opens the Scenes 
window to specify the chapters.  

• Click the “Generate playmarks” button  

• In the window that opens, specify the number of chapter 
(play)marks to generate. The number to specify should be 
duration of the movie divided by 5 minutes (e.g. 6 for a 30 
minutes movie). 

 
 

• Click “OK”. This will generate the number of chapters plus a 
mark at the start and end of the movie. 

• Close the Scenes window. 



 

Part 4: Create the menu 
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BDS Menu Generator 
With the movies specified in the placeholders, they must be addressed 
and started through a menu. 

Menu components 

Menus are the human interface with the movies stored on disc. 
Through menus you navigate to the movie of your choice and activate 
it. 

Menus consist of three parts: 

• A background menu movie that always plays in a loop. This can 
be a short movie but can also be a black short silent movie 
giving the impression to the viewer as if nothing runs 

• Menu texts (usually film titles and options) and images 

• Buttons. These are situated next to menu texts (movie titles) 
that the viewer can select (through the arrow keys on the 
remote control). By pressing OK the selected button is 
activated and the associated movie runs.  

Create a menu 

Like movies each menu has a menu place holder. It is then filled with 
the menu items the user sees on the screen. 

• Create a new menu in the Project Tree window by right 
clicking on “Menus” and select “New menu” from the context 
menu that is shown. Alternatively, you can click on the menu 

button (  ) or press CTRL/Shift/M 

• Enter a descriptive name to the menu (e.g. “Main”) 

 

hen the menu placeholder is created, the “Designer” window is filled 
with a blank menu of size 1920x1080 pixels. Objects such as texts, 
images and buttons can be placed on it. 

Menu movie 

A (short) menu movie must be specified that runs as background of the 
menu. With multiple menus using the same menu movie, transition 
between menus leaves the movie running without interruption. 

Specify the menu movie in the properties window for the menu.  

• The resolution of the menu movie determines the size of the 
menu (1920x1080 or 1280x720 pixels). The “Designer” window 
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always shows the largest menu, but only use 1280x720 pixels 
of it if the menu movie has that resolution. 

• From the kit you can copy the “black silent 5s 24 fps” movie 
into the \films folder if you did not do this already. Then add it 
to the video/audio stream of the main menu. 

 

Menu text 

The background menu text and images are specified from within BDS. 
Create a new menu object in the “Objects” window. Use the “Add” 

button ( ) and select “New Text” from the dropdown list. 

 

This opens the “New Object” window. 

• The text is static 

• The text can be written in any font we made known to BDS 
earlier 
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• You can specify the colour of the text as well as the font size 

• If you want different colours, make additional text objects 

• Click OK when done. This enters an “Item 1” object in the 
Objects window. 

• Click on “Item 1” and the Properties window is now dedicated 
to this Item 1. You can give it a more meaningful name, such as 
“movie titles” 

• The item itself is shown on the “Designer” window in the top 
left corner. 

• Drag the item to the location on the menu where you want it. 

• The yellow square at the bottom can be dragged to enlarge or 
reduce the size of the item.(there is no “proportional resize” 
so be careful when you do this – otherwise the Properties 
window “left”/”top/”height”/”width” properties can also size 
the item). 

 

Add two text objects: one with a title “Star Wars Trailers” and one with 
the texts “Trailer Eps 2 / Trailer Eps 5 / Trailer Eps 9”. Use any colour or 
size you fancy. The colour is set using the colour box and the slider at 
its side determines the intensity. 

Menu buttons 

Each menu item that specifies a movie name must have a button. 

With your remote control you can navigate from button to button. All 
buttons are in the “normal” state. Only the button you navigated to is 
in the “Selected” state. If you press the “OK” button on the remote 
control the menu button that is selected becomes “Activated”. 

Often the “normal” state of buttons is being invisible. The “selected” 
button has an indicator (an arrow, a checkmark). In its properties you 
specify how to navigate to another button or what to do when the 
“OK” button is pressed on the remote. This usually involves either 
playing the movie or opening another menu. 

Create button 
We will create three buttons (one for each movie). Navigation moves 
from button 1 to button 2 and vice versa. Pressing “OK” starts the 
movie whose title is linked with that button. 
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• Create a new menu object in the “Objects” window. Use the 

“Add” button ( ) and select “New image button” 

• The “New Object” window has four tabs – click on the 
“Selected” tab.  

• Ensure the “Image” radio button is selected 

• Navigate to the “buttons” folder of the BDS project and select 
the button image to display (I use “checkmark.png”) 

• Click OK 

 

This way the “Selected” state of the button will show the checkmark. 
All other buttons (in their “Normal” state remain invisible, i.e. have no 
image for that state). 

Position button 
In the Objects window four new items appear with the same name. 
They represent the four states the button can have. 

• Click on the BDS red menu button to make images of buttons 

in the “selected” state visible in the Designer window.  

• The checkmark is now visible at the left top of the menu. 

• Drag it to position it next to the “movie 1” menu text made 
earlier 

• Use the yellow square to resize the button if necessary 

 

• In the Properties window of the button, change its name from 
“Item 1” into something descriptive, such as “movie 1” 

Specify Activate action 
• Click on the “>” button at the end of the “OK Press ENTER” 

property and navigate to “Play movie” > “Movie 1” > “Chapter 
1”.  This will start the movie in placeholder “movie 1” from the 
start (chapter 1) 
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Duplicate button and modify properties 
• Select the button on the Designer Window and right click. 

• Select “Copy to” . This will give one option in our case: “main 
menu”.  

• Click OK.  A copy of the button is made on top of the original 
button. Therefore you may not see it as new button. 

• Select the button image and drag it to the other menu text 
“Movie 2”. You will now have two button images. The 
properties of the selected one show in the Properties window. 

• Rename the button to something descriptive like “movie 2” in 
its properties window.  

• Set the “OK Press Enter” value to start the movie in movie 
placeholder 2, chapter 1 

• Repeat the copy operation for a third button that starts movie 
3. 

Add navigation 
Now the buttons are positioned and play a movie when selected and 
the remote control OK button is pressed, we still need to be able to 
move from one button to the next. 

We will show  how to move from button 1 to button 2. The navigation 
from button 2 to button 1 is just the reverse. 

• Select the button with name “movie 1” in either the Objects 
window or the Designer window. This makes the Properties 
window show the properties of that button. 

• Click on the “>” button at the end of the “Press Down” 
property 

• Navigate to “Select button” > “Movie 2” 

• Do the same for “Press Up” property pointing to “Movie 3” 
(this will create a circular loop) 

• Complete the navigation so that the “Press Down” moves from 
button “movie 1” to “movie 2”. Button “movie 2” moves to  
button“movie 3”. Button “movie 3” moves to button “movie 
1” again. Continue in the opposite way: “Press Up” repeatedly 
moves from button “movie 1” to button “movie 3” to button 
“movie 2” back to button “movie 1” again. 
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All buttons will be in their “normal” state and without an image for 
that state, remain invisible. Only one button is pre-selected and shows 
its checkmark image. By pressing an up or down arrow key, another 
button becomes selected and shows itself. 

Revisit movies 
Now that menus exist, we need to complete the properties of the 
movies. 

• Select the “movie 1” movie placeholder in the Movies list to 
show its properties in the Properties window 

• For “End Action” navigate to “Jump MENU” > “Main” > “Movie 
2”. This is the “movie 2” button. When the movie ends, the 
Main menu is shown and button “movie 2” becomes selected. 
This action happens when the movie ends. 

• Repeat these steps so that the end playing of movie 2 ends on 
the main menu at button “movie 3” and the end of playing 
movie 3 selects button “movie 1” again. 

• For “Popup menu” navigate to “Jump MENU” > “Main” > 
Default. If during movie playback you press the “popup” 
button on the remote control, the movie stops and the Main 
menu is shown again. 

• Repeat the previous step for all movie placeholders 

 

Check menu 
To ensure all navigation and activations have been set correctly, you 
can and should test the menu. To do this, follow these steps: 

• Specify the starting action when the disc is played. This is 
specified as the "Startup Action" for the JAR file that is opened 
when the disc starts playing. The entire disc runs by executing 
JAVA code stored in one or more Java ARchive files – JAR for 
short. In this first disc project there is only a single JAR file, 
named 000000.  

• Open the JARs window (if not shown, press F12).  select the 
000000 JAR file and right click on the "Startup Action" and 
select Menu > Main > Movie 1   The last part is the button the 
menu that will play Movie 1. 
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• Click on the “play” button of the BDS menu ( ) 

• The menu simulator starts. Use the keyboard arrow keys to 
move between buttons to check if navigation is complete 

• Press on the ENTER key to activate the selected button. 
Normally this would play the movie, here just a black screen is 
shown. Press the END keyboard key to simulate the movie 
ended. Or press  F5 to simulate the pressing of  the popup  
key.



 

Part 5: Create and burn disc 
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Create the disc 
All steps are now taken. The movies are present, the menus created 
with buttons that activate the movies. BDS can now use all the 
information to create the disc. 

 

• Ensure the”mux” button of BDS is set to “Mux by tsMuxer” 

• Ensure the location of tsMuxer is specified in Tools > Options > 
tab “muxers” 

• Click on “muxer” ( ) This opens the project properties 
window. 

• Specify the output -folder in which the disc image must be 
made (use the “disc” folder within the project folder tree) 

• Click “OK” 

 

• Sit back and wait for the project to compile the menus and 
mux the video/audio/subtitle streams and connect them to 
the menu buttons. 

• Progress can be seen in the log window of the BDS GUI. 

• If there are no problems, it should finish successfully and 
create and fill the folders  “\disc\BDMV” and 
“\disc\CERTIFICATE”. 
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Play the disc 

Use some software player like PowerDVD to “play movie folder” and 
select the “\disc” folder of the project. The play should start with the 
menu and button specified in “On JAR startup”. Here it will be the one 
and only Main menu at button for “movie 1”. 

 

Burn the disc 

• Use ImgBurn to burn the project to a writeable bluray disc 

• Select “Write files/folders to disc” 
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• Select the “folder” button (  ) and navigate to “\disc\BDMV” 
and add this to the folder list. 

• Do the same for “\disc\CERTIFICATE” 

• Specify a disc label in the “Labels” tab  

• Press the “Burn” button. 

• ImgBurn will inform you it thinks you want to create a bluray 
and therefore sets mode and UFD file structure accordingly. 

• Confirm and let the burn process start. 

 

When finished, take the disc to a standalone player and play it. Or 
leave the disc in the pc and use a software player to play the disc. 



 

Next… 
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BDS capabilities 
Now you made your first, perhaps not so exciting, bluray disc, imagine 
you want more. BDS allows you to be more creative if you use all of its 
capabilities. To understand these features , you may need to read the 
User’s Guide on BDS that discusses most of the possible features. 

To wet your appetite: 

Menu 
• Move some menu elements in and out of screen: animation 

• Use different button images 

• Have multiple menus that invoke each other as well as give 
access to the movies 

• Remember earlier choices made in menus (like preferred 
language audio track) 

• Use Photoshop to create menu images and buttons instead of 
BDS own menu creation 

• Avoid the maximum size of all images together by spreading 
them over multiple JAR files 

• Perform multiple actions or select some depending on 
conditions when you press a remote control button 

• Put actions between the red/green/yellow/blue buttons on 
your remote control 

• Add playlists (like a “play all” option instead of individual 
movies) 

Movie 
• Create slide shows from stills run as a movie (MX only) 

• Allow picture-in-picture (behind the scene footage within the 
main movie) (MX only) 

• Jump between chapters (chaining movies, skipping titles) 

• Create chapter menus as list or caroussel or a timeline through 
wizards almost automatically. 

• Insert “points of return” 

Disc 
• Resume disc playing when it is re-inserted into the player 

• Make 3D movie discs 

• Use Javascript programming to do many more things not 
available behind a BDS button or menu option (such as Easter 
Eggs, bookmarks to return to). In fact with programming the 
sky is the limit in possibilities. 

So dig out the BDS User’s Guide  and create the bluray disc you always 
wanted to create. 


